The Perfect Database Server: Firebird 2.5.3 And FreeBSD 10
Here is the guide on installing Firebird 2.5.3 from FreeBSD 10 Ports and
creating your first test database; also we show you how to install
Flamerobin GUI (administration tool) and the PHP driver for it. This was tested on fresh FreeBSD 10 on a kvm-linux virtual machine.
Download a compressed snapshot of the Ports Collection into /var/db/portsnap.
# portsnap fetch
Or update it.
If you are running Portsnap for the first time, extract the snapshot into /usr/ports:
# portsnap extract
If you already have a populated /usr/ports directory and you are just updating, run the following command instead:
# portsnap update
Enter firebird server ports directory:
# cd /usr/ports/databases/firebird25-server
Compile and install firebird server:
# make -DPACKAGE_BUILDING
# make install
Enable it by adding
firebird_enable="YES"
in
/etc/rc.conf.
Start it with:
# /usr/local/etc/rc.d/firebird start
logs and security2.fdb seems to be in /var/db/firebird.
# /usr/local/bin/isql-fb
To create a new database:
SQL> create database “tmp/first_database.fdb”;
SQL> connect “/tmp/first_database.fdb” ;
Commit current transaction (y/n)? <– y
Committing.
Database: “/tmp/first_database.fdb”
SQL>
If you want to create a simple table then insert 1-2 rows and select from it; here is one example:
SQL> CREATE TABLE TEST (ID INT NOT NULL PRIMARY KEY, NAME VARCHAR(20));
SQL> show tables;
TEST
SQL> INSERT INTO TEST VALUES (1, ‘John’);
SQL> INSERT INTO TEST VALUES (2, ‘Joe’);
SQL> select * from test;
ID NAME
============ ====================
1 John
2 Joe
To quit the isql-fb console, type quit:
SQL> quit
CON>;
For a good open source GUI admin tool you might check the flamerobin administration tool included in ports repository; it can be installed by a simple:
# cd /usr/ports/databases/flamerobin/ && make install clean
Or if you don’t want to wait use pkg-add
# pkg-add -r flamerobin
To use firebird with php, you will need the php5 driver:
# cd /usr/ports/databases/php5-interbase/ && make install clean
You can choose to compile php with apache support (I have chosen cli, cgi , and apache support);
check it if is enabled with:
# /usr/local/bin/php -m
Or if you don’t want to wait compile all the php use pkg-add
# pkg-add -r php5-interbase